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The First Lesson Computer System Basics 
( Introduction ) 
 What is a Computer? 
  It is an electronic set which has the ability to store data and process them to reach certain results 
 {information} by doing logical and mathematical processes using series of logical arranged instructions 
 called the program. 

Some Modern Computer Shapes  
 The computer is used in all everyday fields, when we call it so, the personal computer comes to our minds 
 {desktop and laptop}. The computer appears in different shapes, size and do a lot of different jobs in our 
 daily life .They can be classified according to speed, cost and size……etc. 

 

 Dear student: (enrichment)  
 The school administration has the desire to use the computer system instead of the traditional manual  
 system to save and process data, print the final reports related to students and calculate the staff salaries 
  and the school buffet sales.  

 Enrichment   
 With the help of your teacher and cooperation with your mates, determine the elements which the school 
  administration needs to generalize using the electronic system and determine the relation among the main 
 components of the computer system. 

The main elements of computer system 
 The computer system consists of several elements working together to enable the computer to do its 

function. The most important elements are:     

 

Data & InformationData & 
  Dear students: 
  Is there difference between Data and Information? Cooperate with your classmates; search the internet to 
  find the difference between data and information. 

   Data: 
 They are set of facts that can be obtained by observation or watching. These 
   data can be text ,number ,character, image , video ,audio..etc .  

  (Information): 
 Data are processed by classifying, organizing and analyzing to have sense to  
achieve certain goal (objective). They may be in the form of reports, tables and   

 charts ……….. etc. 
The following diagram shows the difference between data and information    

 

The day : ……...                                                                                                              The date:       /    /             
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SECONDLY: HARDWARE 
   Hardware is the actual content of the computer device which can be observed and touched. They include 
 system unit, the screen, keyboard, the mouse………… etc. They can be divided into: 

 
  1. Input units: The devices and units which are responsible for inputting different data into the device 
 2. Output units: The devices and the units which are responsible for outputting and displaying information 
  and the results  
  that the computer processed and executed according to the user's instructions 
  3- Storage unit: It is used to store data that can be retrieved (got back) at any time according to the user's 
   need. The contents   can't be lost when the electricity turns off. 

 
    Dear student: 
  Cooperate with your mates; classify the set units in the following images: 
  1. Input unit                             2. Output unit                        3. Storage unit 

 

    Tip: There are some units that can be used to input and output together such as Touch screen. 

 

Hardware 
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4) System Unit( 
   The most important components of the system unit:  
  - The main memory unit            - Processor                - Motherboard 
 

- Random Access Memory (Temporary Memory RAM): 
It loses its contents when the electricity turns off. It is the part that the user deals with. 

  - (ROM): 
It contains all the main programs to start the device on (BIOS). Its contents are saved by the producer 
company. It is called Read-only Memory because it is legible. Never can you write on. It is called the 
permanent memory because its contents are never affected by turning the electricity off and it can save its 
content permanently. 

  Dear student: 
 Cooperate with your mates to compare between RAM & ROM. 

 

Central Processing Unit (CPU) 
    (CPU) is responsible for doing any logical and mathematical processes which lead to data Processing  
  according to the orders and instructions of the different programs. 

 The processor consists of two main units: 

  o Arithmetic and logic unit (ALU).                                   o Control unit (CU). 

 
     Tip.: (enrichment)  Processor, RAM & ROM can be constructed inside the computer case.  

 
  With the help of your teacher and cooperation with your mates. 
  - Identify the unit of measuring the capacity of the computer memory. 
  - Identify the unit of measuring the processor speed in your personal computer. 

 

storage capacity) -Measuring units (The processor speed  
  1-Storage Units: 
  Byte : can be used in most computer systems as a unit of measuring data. It is used to represent a letter 
  or a symbol. It consists of 8 bits. Storage unit can be measured by doubling Byte. 
 Bit: represents passing or not passing the electric current. It takes the value of 0 or 1 as 1 represents 
 passing the electric current (on) and 0 represents not passing the electric current (off). 

  1 Byte = 8 bits a unit of measuring storage capacity 
  1 Kbyte = 1024 Bytes a unit of measuring units of computer storage.  
  1 Kbyte = 1024 bytes (kilobyte) 
  1 M byte= 1024 kbytes (Megabyte) 
  1 G byte = 1024 M bytes (Gigabyte) 

1024 Gbyte (Tirabyte)  1 T byte =   
 The order of units of measuring storage capacity from the smallest 
 to the  biggest (A to Z) (enrichment) 

 

The day : ……...                                                                                                              The date:       /    /             
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To change among the units of measuring: (enrichment)   

 
    Tip: 
 When you change from Bit into Byte divide by 8 

When you change from Byte into Bit you, multiply by 8 and so   
  does the rest of changes (/) means division process instead of (÷) in arithmetic system.  

   2- The unit of measuring the processor speed : 
Hertz (HZ) and its doubling is the unit of measuring the processor speed. 

 

THIRDLY: SOFTWARE 
   Software is a set of programs used to operate the computer and employ it to do different tasks. 

 
A type of programs where you can't read its source code. It is only available  Closed Source Programs  

for programmers or designers; (The source code is the programming code of the program).  

 
g, developmentThey are the programs of source code available for use, editin Open Source Programs:    

                                           and distribution. 

 
The comparison between open and closed source programs: -    

Closed source Open source 

Determine costs according to the usage license Available for free 

Developing the source code is done by the 
programmers of the owners only 

The source code is available for all to modify and develop it 

Not allowed for use but after getting the license. Distributing programs to others without restriction is available 

  Dear students: 
  With the help of your teachers; Is this phrase right or wrong, and why? 
 - All open source programs are free but not all free programs are open source. ( ) 
- Software is divided into three types according to the copy rights: (enrichment) 
1- Freeware: 
The responsible company lets the user make full use of it for free. 

2- Shareware: 
 Shareware is an experimental copy for the original software with limited abilities or limited time and when 
  time is up/over, shareware must be bought. 
 3- Software that can't be used except by buying the original copy. 
  It is protected by ID. 
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Remember 

   Computer : It is an electronic device with ability to store data and process them to reach certain results  
(information) by doing some logical and mathematical processes using a series of logically arranged 
orders (instructions) called the program. 
 The main content of computer: Human ware – software – hardware – Data and information. 
 The computer hardware components : Input units – output units – storage units – system unit. 
The most important components of system unit. 
- The main memory unit - Mother board - CPU central processing unit (Processor) 
The Processor consists of two main units: 
- Arithmetic and Logic Unit (ALU)          - Control Unit (CU) 

 -programs used to operate the computer and employ it to do different tasks: Software is a set of   
Closed Source Programs - Open Source Programs  

-According to the copy rights, software is divided into three kinds:  
 Freeware - Shareware - Software that can't be used except by buying the original copy  

 

   First question: Choose the correct answers: 
1. "Touch screen" is one of …………….. units. 
A) Input only                                      C) output only 
B) Input and output                           D) None of all mentioned 
2." ………………… "is one of the output units. 
A) Printer                                            C) Keyboard 
B) The mouth                                     D) Microphone 
3. "…………………"is the memory which keep data temporarily. 
A) RAM                                                C) ROM 
B) Flash Memory                                D) All mentioned 
4. Three Kbytes is equal to…….. bytes. 
A) 3 X 1024                                          C) 1024 X 1024 X 1024 
B) 3 X 1000                                          D) nothing of what was mentioned 
Second question: Complete the following: 
1. …………. , …………. , …………. are examples of computers 
2. …………. , …………. , …………. are computer system elements. 
3. …………. , …………. , …………. are of the output units. 
4. ………………………………………….. is the unit of measuring the processor speed. 
Third question: Answer the following questions: 
1. Why is the permanent memory unit called so? 
2. What do you mean by open source programs? 
3. Show the difference between: freeware – shareware 

 

 

 

 



  7                  term Talkha administration - computer orientation - class brochure for the first year of middle school, first  

 

 

Lesson two Operating Systems 

         Operating system is the most important kind of computer programs as there must be an operating 
system installed in the computer to be able to run the other types of different programs and applications 
and managing the Hardware of the computer. Operating system is the main structure of the computer 
system as the computer searches for it every time on starting inside one of the storage units (often H.D). 
Then, the operating system is loaded inside RAM. Hence, the computer becomes ready to receive the user's 
command or instructions. 
Operating system definition: It is a set of programs responsible for managing the hardware of the 
computer. On one hand it is a bridge between the user and his programs and the hardware on the other 
hand.  
Operating systems are responsible for managing: 
 • Computer hardware                      • Applications                       • Command prompt is where the user can 
prompt commands to operating system or through graphical user interface(GUI). 

ems where the user prompts commands It is called "Terminal" in some operating syst Command Prompt:

to the operating system from command prompt using the keyboard.   

Graphical User Interface (GUI ) 

   It contains some different commands and instructions in the form of menus, graphics , tool bars and the 
basic input unit is the mouse that makes computer more interesting. 

 
  The user can prompt commands in two ways: 
     • Command Prompt               • GUI 

Operating systems Jobs 

    Operating system has several tasks and functions to do related to operating computer, controlling its 
contents, Hardware and Software. 
We can define some tasks of operating systems in the following points: 

The most operating system functions are to: (enrichment) 
• manage storage units and the other components of computer (printer – scanner). 
• organize the software dealing with memory. 
• transmit data among the different units and save them on storage. 
• secure (password – different user validity). 
• provide interface for users through which the user can deal with computer. 

 

)ating Systems (Open or closed SourceOper  

  Previously, we referred that software can be classified into open and closed  
source. Hence, we can classify operating systems into 

 
 

The day : ……...                                                                                                              The date:       /    /             
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Closed source operating systems: 

specified for apple Mac devices   is an operating system • Mac OS X 

that is attractive and easy to use 

• Windows : 

One of the most famous operating systems and more common for personal computer. 
 

- Open source operating system: 

Linux: Open source operating system – easy to use and developable. 

A lot of its distributions are found (available) and the most famous are Ubuntu, Fedora 
 
 
 

 
 

 

Mobile phones operating systems: 

There are open and closed source operating systems for mobile phones. On purchasing, operating 

systems and software applications are important factors especially when the technological specifications 

of mobile phones are approximated with each other. Android is one of the open-operating systems. It is not 

only used in Mobile phones but also in tablets. 
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Characteristics of GUI 

 It provides the user with graphic user interface which allows: 

 Showing programs in the regular window frames. 

 Using simple drop down menu and tool bars. 

 The capability of operating several programs at the same time. 

 The capability of using Arabic and other languages as application interface. 

 Provide web browsers for web sites pages. 

 
   Dear student: 
- There are some specific icons for operating system write the operating system name which refers to each icon. 
- Cooperate with your teacher; look for examples of Mobile phone operating systems. 

 
Opening Screen of the Operating System 

  On turning on the computer, it makes sure of the safety of main units such as temporary memory (RAM), Keyboard, 
screen and disc drivers. The self-test program which found in ROM can do that; In case of having no problems, 
operating system starts then, the opening screen appears for user to start achieving his work. 

 
 There is similarity among the main components of the starting screen in different opening systems. 
-Background: is a color or image that can be changed by the user. 
-Icons: small symbols used in running different programs quickly as soon as you double click the left button of the mouse. 

group of symbols of installed software on operating systems and others related to the important  Bars:-
preparations of the system such as time and date setting and sound control and the network 
Tip:The computer can contain more than one operating system but on starting, choose one of them to be loaded. 

Dear student: 
With the help of your teacher, do the following: 
• Choose and load one of the operating systems installed on your computer such as windows. 
• Write three icons names found on the desktop. 
• Change the background (image or color) 
• Adjust time and date 
• Look for one of the programs to change the image. 
• Search for internet transverse icon, load internet transverse program. 
• Load Ministry of Education website. 

 Look for one of the text editors and write your notes about the ministry website using text editor. 

The day : ……...                                                                                                              The date:       /    /             
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Remember 

  Operating system: a set of programs responsible for managing the Hardware moreover, it is considered a 
means between the user and his programs on one hand and the Hardware on the other hand. 
 Operating system is responsible for: • The Hardware of the computer • Software applications 
Operating system functions: 
• To control storage units and the other components such as printer, scanner………..etc. 
• Organizing the software dealing with memory 
• Data transmission among different units of the computer and keeping in storage units. 
• Security (password – user different validity). 
• provide interface for the user through which he can deal with the computer. * There are different closed 
and open source operating systems. 
Modern operating systems are distinguished with: 
- providing GUI for the user as it provides: 
• Program display in the form of organized windows. 
• Using the simple drop-down menu and toolbars. 
• The main components of the main screen are similar among the different operating systems.  

 

 The first question: Tick (√) in front of the right phrases and (×) in front of the false ones 
• Operating system must be installed on the computer to be able to operate the rest kinds of different 
programs and applications                                                                                                                                 ( ) 
• The user can prompt commands and instructions of the operating system through command prompt ( ) 
• MAC OS X is one of the open source operating systems.                                                                             ( ) 
• Android is an open source operating system.                                                                                                ( ) 

The second question: 
• Define three functions of operating system? 
• Show the most important advantage of (GUI) graphical user interface? 

• What is the main function of self-test program?    
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The Third Lesson Dealing with files and folders 

  One of the most advantages of operating system is to control files  
management and organize them in folders and indexes. 
Each operating system depends on kind of file systems which 
 is used for how to store, restore, organize and manage files. 

dealing with filesFirstly  

Files are the most important sources used on dealing with operating system; each text document , image , 
video or audio you deal with is a file. To be able to manage files and deal with them efficiently, we must 
collect and arrange those files logically, this can be done in operating systems by creating folders 
including connected files inside them. 
Tip: 

 All processes carried out by the computer are Kept inside RAM and when the electricity is off this 

temporary memory loses its contents. 

 To keep your doings permanently, you should save them in the file on a storage unit. 

Dear students :With the help of your teacher, compare between the different storage units concerning 

the storage capacity as follows:    

 
  File : 
Is a set of data which is stored in storage units in different kinds and extensions. The user can deal with it 
on restoring, modifying, deleting, sharing and printing ……etc. 

  File name consists of two parts, the first is the origin name and the second is called extension which 

distinguishes file type. It often consists of 3 letters.  

 The file origin name is separated from its extension with a (dot).  

 The file has certain types which differ according to the application 

 used in its creation. 

  The most important file types  

 

This file contains sound and images. It is created 
by special programs for recording 
 videos or audios. 

Video files: 

 

 

They are created by graphic programs including 
graphic data with different extensions which 
defines the image accuracy, clearance and size. 

Image files: 

 

     

There are several office programs such as MS 
office, libreoffice through which text files are 
created. 

Text files: 

 

 

They belong to the operating systems, programs and 
sets connected to the computer. 

These files must not be played with or deleted so as 
not to affect operating system work badly. 

System files: 

 

File creation and saving 
  Dear student, with the help of your teacher, do the following: 
- create text file through one of the text editor 
- Save this file in one of storage units 

The day : ……...                                                                                                              The date:       /    /             
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  file creation:        1- open one of the text editor programs                     2- Write one of the text phrases  
File saving: 
 - Open file menu.    

  - Chose save as, save as dialogue box appears.  
1. Write the file name in the specific place. 
 2. Define the place in which file be saved.  
 3. Click save. 
 

Note that: File saving ways are similar even if 
 operating systems are different 
Tips: 

 At the first time to save files the command save is similar to save as command. 

 Save as is used to save file copy using new name at the same place or any other place. 

 You can use the short keys in the keyboard (CTRL+S) to save the file. 

 It is preferred to file name to suit its content to be easy to remember. 

 You must remember the place where you saved. 

With the help of your teacher. 
- create an image file and save it using one of the image processing programs available in your computer. 
- Differentiate between save and save as command. 

SAVE AS Save 

Used on creating the file at the first time Used on creating the file for the first time. 

Used on changing the name of the file or saving 
the file after modification and with a desire to 
save the file with different extension 

Used on modifying the file with a desire to save 
the modification at the same file and with the 
same name as it is. 

Searching for a file in the computer (enrichment) 
You can search for the file in different ways: 
- Using the origin name part of it, or by the extension (type).  
This can be done using search command which different  
operating systems provide. 

Tip.: 
Search tape can be shown by pressing (CTRL+F) on the keyboard. 
The search using the name: 
Write part of the file name or the fill name in the search bar then 
 file names appear including the file name. 

The search using file extensions: 
This can be done using the symbol (*) instead of the file  
origin name and write the file extension and they can be  
separated with a dot (.) in the following example, means  
search all files with extension PNG. 
 

Dealing with Folders 
  The more your work is arranged and organized, the less effort you do and the less time you take to reach 
your goal. So you need to organize and arrange your files by putting each connected group in a separate 
place to be easy to reach. 

Folder Definition: 
It is a place inside a storage device which contains a file or more and also other folders called sub-folder. 

Sub-folders: 
The purpose of using folders is an organized process for the 
  Storage units contents to reach the required files easily and  
quickly where operating system allows the user to create 
 several folders with certain names which refers to the 
 folder content. 
Folders have several similar shapes according to  
operating system type and content. 
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foldercreating a  

  To create a folder, do the following steps: 
 Click the mouse in the place where you need to create the folder. Click the right button of the mouse, the 

context menu appears as found in the following shape. 

 Select the New folder command 

 write the folder name. 

 Click "create". 

 
 
 
 

                                      
 With the help of your teacher, create a new a folder in a different way by pressing the following buttons    

 
Tips: 

 The folder may contain files or sub folders. 

 One of the folder properties is to identify its size and the number of its contents (items).  

 
With the help of your teachers, create two folders: 
My work, games in Documents folder found in Home folder as shown in the following diagram shape. 

 

folder cut & copyThe  

 - Cutting The folder: to move the folder with its contents from its current place to a new place at the same 
storage unit or any other storage unit. 

 
   - Copying The folder: make another instance to get spare copy of the file either at the same storage unit 

or any other.  
The folder "copy" steps: with your teacher discuss the steps of the folder copy 

 Using the context menu of the folder. 

 Choose "copy" command. 

 Move to the new place (the same storage unit or the other)  

 display the context. 

 Choose "paste" command then the folder is copied 

 

The day : ……...                                                                                                              The date:       /    /             
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 naming the folder-Re 

  To change the folder name, follow these steps 
 Use the context menu of the folder. 

 Click "Rename" command 

 Write the new name. 

 Click "Rename" 

Folder Delete 

   To delete the folder follow these steps: 
 Using the context menu of the folder. 

 Click "Move to trash" 

restoring the deleted (files or floders): 
Any deleted folder or file can move to trash (the basket where 
 deleted files or folders exist) where it can be restored again  
or deleted forever. 
The steps of restoring deleted file or folder: 

 Move to trash, deleted files or folders appear. 

 Restore the folder or delete it forever. 

 Click "Delete" from Trash to delete the folder forever. 

 Click "restore from Trash" to restore the folder. 

As shown: 

 restoring the deleted files / folders or deleted forever  
  With the help of your teacher do the following steps 
- create a new folder named "games". 
- open it, then create folder "cars" inside it. 
- copy "cars" folder and past it at the same place with  
another name "football". 
- After doing the previous steps, make sure that  
the folder "games" is found and inside it the other  
two folders "cars" "football" are found. 

Remember 

  - One of the most important advantages of operating system is managing files and organizing them in folders and 
indexes. 
 - In order to save your work permanently, they must be saved in files in a storage unit. 

File : is a set of data which is stored in a storage unit with different extensions and types. The user can deal with them 
by restoring, modifying deleting, Sharing, printing ……………etc. 
The file name consists of two syllables – the first is the origin name and the second is called extension which 
determine file type. It often consists of three letters. 

 On saving the file. - For the first time, "save" is equal to "save as" - You can use "save as" to save the file with a 
new name at the same place or another. 

You can search for the file in several ways: 
- Search using a name 
- Search using the file extension The folder definition : - It Is a place in the storage unit containing file or set of files in 
addition, it often contains a folder, other folders called sub folders. - The folder may contain files or sub folders. - One 
of the properties of the folder is to identify its size and the number of its contents. 

delete –Rename  –copy  –cut The folder can be manipulated by:  
On deleting a file or a folder, it moves to Trash where it can be restored or  folders:Restoring the deleted files or  

deleted forever. 

 
The first questions: Put )√( in front of the right phrase and (×) in front of the false ones 

(1) The type of the file can be identified through its icon or extension ( ) 

(2) The permanent delete in Trash can be restored again ( ) 
(3) Cut and paste of the folder means repeating it to get a spare copy either at the same storage unit or at another. 

(4) Files can be saved by using (Shift + S). 

The second question: what is the difference between: 
(1) File and folder                      (2) Save and save as                                      (3) Delete and Delete from Trash 

The third questions: Write the scientific term: 
(1) Files belong to operating system and components connected to computer, never play with it. 
(2) A collection of data which is stored in the storage units in different extension. 
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The Fourth Lesson The Computer Networks 

Computer networks 

 Information and communications are the most important factors for any association to pay off (succeed). 
in the past, each association had a number of computers and communication devices such as )phones, 
faxes ……..( but each one of them worked separately so the association was informatively. 
To solve this problem to benefit from information technology in a better way, there had to be computer 
networks to connect associations together. This is called computer and communication sets integration. 
Computer networks enable their user to reach remote data base found in the same association or others. 
The computer has the power to process data. If it is connected to a network of other computers. It will 
become more powerful and capable of doing different tasks. 
The computer net and its importance: 
It is a connection between two sets or more through a wire or  
wireless means to share the resources (sets and data). 
 The most important benefits of computer net: (enrichment) 
1- The possibility of exchanging data and programs among the net sets. 
2- Sharing the Hardware such as (printer, scanner, different storage units …….etc.) 
3- Data centralization such as the main branch of a  
bank has a computer with data base for the customers' 
 accounts and connected to other computers in the  
other branches of the same bank in order to  
update the data at any branch of the bank. 

 NetworksTypes of      
1- Local Area Network (LAN): 
It is a limited network area inside a building or several  
near buildings. It is used at small institutions, schools, 
 universities or at home. 
2- Wide Area Network (WAN): 
It is used to connect devices separated by long distances like cities, states or continents, so other methods 
are used to connect devices that are different from the local network. The Internet is considered a special 
type of the wide area networks 

 
 
 
 
 
 

File Sharing 
-File Sharing:  
Sharing files is the process of spreading digitally stored information, such as documents, electronic books, 
computer software or multimedia (audio files, video or photos). This is to help accessing any of them 
through computer networks where any files can be shared as well as some of the devices such as a printer 
among different network devices. 
First, Sharing files in Windows Operating System:  
To share a file or a group of files in Windows Operating system the following  
steps are to be followed:  
-Add the files in a folder.  
-Select the folder to be shared (for example the folder, Books), 
 right-click the  mouse then select Share with from the context menu.  

Note: It is important to configure all the network settings.  
(by your teacher). 

The day : ……...                                                                                                              The date:       /    /             
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Select the option “Specific people”, a dialogue box File Sharing appears (the following numbered pictures 
guide towards identifying the steps). 
 

 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1 .Choose the user allowed to share the folder from the drop down list. Let the user be Everyone to allow all 
the users to share the specified folder.  
2 .Press the button add to add this user to the list of users allowed to share.  
3.Different permission can be assigned through Permission level where the choice Read means allowing 
reading the files only and the choice Read/write means allowing reading, modification or deletion.  
4.Press Share to complete fulfilling sharing the folder with special validations.  
To allow your colleagues to reach your available files through the network,they must search for your 
computer through the network. The search for your computer is to be through the name of the computer. 
Activity (1)  
By the help of your teacher identify the name of the computer you are working on. 

What is the name of your computer? 
To know the name of your computer or the one whichyou are working on these steps are to be followed:  
1 .Show the context menu of the Computer icon on the desktop.  
2 .Click on the option Properties.  
3 .The name of the computer is displayed in the item Computer name. 

 
  (2) Activity 

 By the help of your teacher help your colleagues to identify the  

names of their computers. 

 
Accessing your colleagues’ folder (folders) on a network 

Accessing a folder (folders) which was shared through the network by your colleagues:  
1- Double Click on the computer network               icon (Network), the following window which includes all the 
computers of your colleagues who are                   connected to the network appears.  

 
 
2- Search for the required device through its name. By double  
clicking the mouse, you can access the device (in the previous 
 figure the name of the device is WAS_PC) then all the shared  
folders appear as shown in the following window:  
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After accessing the required device on the network, all the folders that were shared on the device appear. 

(2) Activity 
By the help of your teacher do the following:  
- create a folder, copy and paste some of the files to that folder.  
- Share the folder to be available for the rest of your colleagues‟ devices on the network.  
- Compare between Read and Read/Write (This is the permission available to deal with the folder while sharing). 

First: to conduct this activity the teacher does the following:  
-Create a folder entitled Teacher  
-Through a word processing program create a text file that contains a table of students‟ data as follows: "number - the 
student's name - the email address of the student." 

 

- Save the file as Email in the folder Teacher.  
-Share the folder Teacher with the permission of Read/write.  

Second: students do the following through the network:  

-Open the teacher‟s computer through the icon of the network.  

-Open the folder Teacher which is shared with the permission of Read/Write  
-Open the file entitled Email saved in the folder Teacher and register both the name and email address of the student.  
-save the modifications of the file.  

Important Note:  
Using the permission of Read/Write may cause a problem as it allows others through the network to change the 
content shared as well as deleting it totally from your device which may cause damage, falsification or missing the 
information 

Second: Sharing files in Fedora Operating System 
Sharing files in Fedora Operating System:  
Implementing the file sharing in Fedora Operating System could be through allowing the users of the network to 
access a folder entitled Public in the folder Home through other computer devices connected to the same network.  
Consequently, add all the files required for sharing in the Folder Public.  

Settings required allowing others to access the contents of the folder Public:  
1-Click Activities which appears on the top ribbon of Fedora opening screen.  
2-Start by writing the term Sharing in the search box so the Sharing icon appears 
3-By clicking on the Sharing icon a window of configuring the sharing settings is shown. 

 

 

                                                                          
1. Reset the sharing button on the top right of the window to the ON state  
2. Reset Personal File Sharing also to the Active state. 
By doing that other users of the same network can have access to your folder Public through their devices 
accordingly, they can access the files inside it. 
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Remember 
The definition of a computer network and its importance 
It is linking two or more devices through a wired or wireless connection medium to share resources. (Data 
and devices) 
The most important benefits of a computer network: 

- the exchange of data and programs between the devices of the network. 
     - sharing some devices                                 - Centralizing the Data  

computer networks range: The types of 
 - Local Area Network (LAN)                             - Wide Area Network (WAN) 
The concept of File Sharing 
Sharing files is the process of spreading digitally stored information, such as documents, electronic books, 
computer software or multimedia (audio files, video or photos). This is to help accessing any of them 
through computer networks where any files can be shared as well as some of the devices such as a printer 
among different network devices. 
 
 
 

 
Question 1: Mark ( √ ) on the right statement and (x) on the wrong one:  
1- Linking devices together within a computer network gives the possibility of sharing the data only(    ) .  

2- The Internet is considered a special type of wide area networks) ( .  

3- The wide range network uses different methods than that of the local network to maintain connectivity(  )  

4- To share folders, your device must be connected to the network to help other users to reach it. ( )  

5- To share files in Windows Operating System, It is not necessary to be added in a folder(     )  

6- Specifying the user Everyone to share a folder in Windows Operating System means allowing all users to share it ( )  

7- The Computer icon is used to access the shared folders in Windows Operating System(     )  

8- Sharing files in the Fedora Operating System is to be implemented through allowing the network users to 
access a folder Document(     ).  

9- To make the process of sharing files accessible in Fedora Operating System, the sharing setting must be 
set upon an Off state. ( )  
Question 2: Complete the sentences using the words between brackets  

(files - size - data - users - the name - research - devises) 

1. One of the most important benefits of the network is centralizing ........ .................... 

2. The local network is a limited network in the ........ .................... 
3. Sharing ........ ....................is a process of spreading digitally stored information.  
4. Searching for accessing required device on the network is to be through .... ........... 
5. It is possible to other ..................to access the files that you shared through accessing your folder Public.  
6. The term Sharing is written in t ......................dialog box to access the Sharing icon.  
Question 3: Answer the following questions:  
- Mention the most important benefits of computer networks?  
- The type of network differs according to the geographical area it occupies. Mention two types of networks range?  

- Using the Read/Write option may cause a problem to users when sharing folders. Explain  
Question 4: rearrange the following steps to share a folder in Windows Operating System:  
( ) Choose the user allowed to share the folder.  
( ) Choose the option Specific people then a dialogue box File Sharing appears.  
( ) click ADD to add this user to the list of users who are allowed to share.  
( ) open the context menu of the folder to choose the command Share with.  
( ) Press Share to complete sharing the folder. 
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Unit 2  Creating and Modifying Images 

Lesson 1 Introduction to the Basics of Creating and Modifying Images 

 

creating and modifying images Programs 
The programs of creating and modifying images used to assist in designing, creating and modifying 
different images. It enables the user to modify photos or drawings. There are many of those programs 
which are a closed and open source programs. 

Activity (1) 
)  Searching for some programs of creating and modifying images 

 By the help of your teacher, surf the Internet to search for some programs of creating and modifying images 

 There are various programs to create and modify images such as: 

 

Loading the GIMP program to create and modify images 
The GIMP program is an open and free source that allows creating and processing images. 

Activity (2) 
Load GIMP program 
By the help of your teacher, download GIMP program. 
The Interface of the GIMP program is available in two forms. 
- Multi-window mode.                                    - Single-window mode 

 
Important Note: 
When opening the GIMP program for the first time,it is usually on (the multi-window mode). 
-To facsilite the using the program, It could be in the (Single window mode from the 
 Windows menu: → Single-Window Mode 
The program interface is shown in the mode (single window mode) as shown in the following figure: 
 
 
 
 
 
 
 
 

Identifying the contents of the GIMP program interface 

The day : ……...                                                                                                                                    The date:       /    

/             



  21                  term Talkha administration - computer orientation - class brochure for the first year of middle school, first  

Identifying the contents of the GIMP program interface 

 
The GIMP program default Interface consists of : 
1.The Main Toolbox: 
The "tool box" consists of many tools such as the selection tools, back and front color tools.... 

2 .The Tool options dock:" 
It appears below the tool box and the options of the current tool (the selected) is shown in it. 

3. "Image windows: 
when opening more than one image, each image appears in a window which you 
can navigate between them. 

4 .(The Layers/Channels/paths/Undo) dock:It contains several classifications, such as the Layers tab. 

5 .(Brushes/Patterns/Gradients) dock: 
 It contains the clssification of Brushes, Forms tab, Gradients color schemes tab. 

chment)Activity (3) (enri 

To learn more about the program interface.. 
By the help of your teacher, 
Open the program, to know more about the GIMP program do the following: 
1- Move the mouse pointer on the tool required to be known and wait for moments, the tooltip related to it is 
shown as well as its shortcut key . 
2- To know more about the tool select the tool, click F1 from the keyboard to open the Help of this program. 
(bearing in mind to have your computer connected to the Internet). 

Using the F1 "help" to identify the contents of the Program Interface (enrichment) 
The Main Toolbox is considered the program main window contents which consists of many tools such as 
the selection tools .Through the Help which appears by clicking F1 from the keyboard you can identify the 
different contents of the program interface as well as get more information. 

Activity (4) (enrichment) 
By the help of your teacher, open the GIMP do thefollowing: 
1- Click on one of the tools like "Rectangle" 
2- Read the note about it . 
3- Click on F1 to show the program Help. 
4- Identify some of the selection tools through the program Help. 

Important notes: (enrichment) 
1- In the case of closing one of those boxes or tabs  
(tool box, selction tools box,....) It 
can be restored through the Windows menus → Recently Closed Docks 
2- To add , close or move one of the tabs in the box, click on the top  
right corner to open a drop-down menu and choose the required one. 
For more information on the GIMP program to create and process imagesvisit the link 
http://docs.gimp.org/2.8/en of the program 
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Selection Tools 
 

The selection tools are used to select a part or more of the image 
 to  deal with, like delete, cut, copy, paste, change the color of  
the selected part in order not to change the whole image. 
There are many selection tools used to specify part of the image, 
 each one of them has a specific way to use it. The selection 
 tools are shown in The Main Toolbox you can also access  
it through the Tools menu From the Tools Menu  
select Selection Tools 

1-Rectangle selection Tool 
Choose the selection tool "Rectangle" by clicking on the tools box. 
To select, click by pushing the image in the selected place so a rectangle is drawn 
as shown in the image 

 
Activity (5) 
Select part of the image with the rectangle tool. 
By the help of your teacher, open the file of the previous image from the folder "Images" and do the following: 

1- Use the selection tool "Rectangle" to select the part of the image. 
2- Move the cursor inside and outside the selection. observing the shape of the cursor. 
3- Click by pushing when the shape of the cursor is changed. 
4- Deduce the difference between the different shapes of the cursor 

Note: 

1- The cursor in the selection area that takes the shape of   where you can move the selection rectangle. 

2- the cursor outside the selection area that takes the shape of   by clicking and pushing the selection 
place is changed. 

)6Activity ( 
Deducing the aim of the selection. 
By the help of your teacher, do the following: 
1- in the previous example, after using the selection 
tool "Rectangle" and select the image do the following: 
- change the front color in of the tool box to Red 
- choose the "Pencil" tool. 
- try to draw the lines with the "Pencil" tool inside and outside the selection. 
- write down your notes.- 
Deduce the aim of using the "Rectangle" selection tools. 
- draw red lines in the selected part only. 
- to finish the selection and exit: 
From the Select menu Select None or( from 
the keyboard, click the 
( Shift key + CTRL + A ). 

 

The day : ……...                                                                                                              The date:       /    /             
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Ellipse Selection Tool -2 

The Ellipse select tool is used to select the oval 
shape of the image 

Activity (7) 
Select the oval shaped part of the Image using the Ellipse selection tool. 
By the help of your teacher do the 
following steps: 
1- Open the image file from the "images" 
folder. 
2- Select the Ellipse selection tool. 
3- Select part of the image using the 
Ellipse selection tool. 

 
Lasso free selection Tool -3 

The Lasso Free Selection tool is used to select an irregular 
part of the image in a freeway. 

)8Activity ( 
Select a part of the Image using the Lasso tool 
By the help of your teacher, use a free 
selection tool to select a part of the image as 
shown in the image : 
1- Use the image of the previous activity. 
2- Select a part of the image using Lasso free 
selection tool 
3- from the Edit menu choose Cut. 

Write down your notes. 
Note: 
- a selected part cut. 
- to remove the selection, from the Select menu select None 

Fuzzy Selection (Magic Wand) tool -4 
The Magic wand tool or Fuzzy Selection tool is used to 
specify similar color schemes areas of the image. 

)9Activity ( 
Specifying similar color schemes areas of the image with the Fuzzy tool. 

By the help of your teacher do the following: 
1- Open the image file from the folder "images" 

2- Select the similar color schemes of the Image using the Fuzzy tool 
 
 
 
 
 
 
 
 
 

Selection toolSmart Scissors  -5 
The Smart Scissors selection tool is considered a useful 
tool when trying to specify an area specified or 
distinguished with a clear and strong color where the 
colors of the borders are changed in a clear manner 
To use this tool, click on the points by pushing the 
area with distinguished color from the rest of the other 
ones. 
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)10Activity ( 
Specifying part of the image tool using the smart Scissors 
By the help of your teacher ,do the following steps: 
1- Open the image file from the folder "images." 
2- Use the Smart Scissors to make points by  
clicking and pushing on the area of 
distinguished color from the rest  
(the borders of the flower) as shown in the 
following figure: 

Remember 

The GIMP program is an open and free source program that allows creating and processing images. 
When opening the GIMP program for the first time it is usually on (the multi-window mode). 
- To facility using the program, It could be in the (Single window mode from the Windows menu → Single-Window Mode 

The GIMP program default Interface consists of : 
1.The Main Toolbox .            2 .The Tool options Dock.                3 .mage windows. 
4 . (The Layers/Channels/paths/Undo) Dock.                                 5. (Brushes/Patterns/Gradients) Dock. 
To know more about the tool select it, click F1 from the keyboard to open the Help of this program 
-To restore any closed tabs: 
Windows menu → Recently Closed Docks 

- The selection tools are used to select a part or more of the image. use the selection tools to select one or more of 
the image, 
- The selection tools ( Rectangle tool, Ellipse tool, Free Selection (Lasso), Magic Wand tool or Fuzzy Selection and 
Smart Scissors ) 

 

Question1: Mark ( √ ) on the right statement and (x) on the wrong one: 
1- On opening the GIMP program for the first time ,the program is shown in the multi window-
window mode ( ). 
2- For more information about one of the tools ,click F5 from the keyboard ( ). 
3- Use the "Selection" tool to draw the image freely ( ). 
4- The "Pencil tool" is considered one of the selection tools ( ). 
5- The "Ellipse" selection tool is used to select an oval shape of the image. ( ). 

Question2: Complete the following: 
1- To delete the selection, Choose ............................... 
2- The "Lasso" Free Selection tool is used to select ................. 
3- The "Magic wand" tool or "Fuzzy Selection" is used to select ........... 
4- The " smart Scissors " selection tool is used to select.............. 
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Lesson 2 Designing and Creating New Images 

Create a new image file (File         menu new) 
To create a new image file (New Image) from the File menu choose New, a dialogue box appears 
which requests the dimensions of the new image (length and width), its resolution, color scheme 
and its filling color To create a new image file   (  File menu           New ) 
 
 
 
 
 
 
 
 
 
 
                                                               1-Template: Templates are ready made designs previously 
                                                              prepared of the dimensions and the resolution of the 
                                                              picture. by clicking on the drop down list a template 
                                                              appears to select from instead of selecting manually. 
2- Image Size: To identify the dimensions of the new image (length and width) click on the arrows . 
3- Advanced Options :by clicking on + sign The rest of the dialogue box appears as follows: 

  

4- X resolution and Y resolution: This is used to determine the image resolution when printing (and it does 
not affect the picture dimension) 
5- Color Space: This is used to determine the Image color system RGB using red,green and blue colors or 
that of the grayscale using black and white colors and the gradients of grey between them. 
6- Fill with: issued to specify the new image filling color which can be: 
- Background Color which appears in the Toolbox.        - Foreground Color which appears in the Toolbox. 
- White filling the image in white color. 
-Transparency the transparency of the image is to make the background of the image transparent. 
Create a new image file using Template to specify the dimensions, background color and the filling color of 
the new image. 
By the help of your teacher, create a new image of (600 X 800) and fill its background color. 
In the opposite figure the color of the                       background is shown in white. 
 

-to choose another color of the background click on the toolbox of Background Color in the dialogue box. 
-To open a dialogue box to change the background color "Change Background Color" do the following: 
1- click by pulling to change the current background color. 
2. Current: Is the color of the current background.                   3. Click "OK". 
- From the File Menu Choose New. 
A dialogue box of a new image appears to choose the following: 
- From Template Choose 600 X 800          - From Fill with Choose Background Color. 
- Click "OK".                                                - The new image is shown in this Figure. 
 

The day : ...............................................                                            The date :.................................. 



  25                  term Talkha administration - computer orientation - class brochure for the first year of middle school, first  

 

 

 

 

 

 

 

Design simple Drawings 
Activity (2)  
By the help of your teacher use one of the selection tools to try implementing the next drawing: 

Steps of the activity 
-Create a new file from the File menu and select New, a dialogue box appears to select the dimensions of 
the new image. 
 
 
 
 
 
 
 
Choose the "lasso" free selection tool to draw the abbreviation "EG" as follows: 
1- To draw the first letter "E" ,click by pulling the free selection tool until the completion of drawing the letter. 

2- To draw the second Letter "G", it should be noted that when you click by pulling to draw it the first letter 
"E" disappears. 
3- To keep the previous specified selection of the "Lasso" free selection tool click on to "Add to current Select". 

4. Choose the color filling "Bucket Fill" Tool, click inside this selection to fill it with the front color. 
 
 
 
 
 
 
 
 
 

Activity (3)   By the help of your teacher, draw the following figure:  
To draw the figure ,you must try the following: 
- A careful look to the figure or image. 
- Try to guess the tools that will be used.                 - Identify the starting point. 
Note that: the figure is composed of a group of oval shapes, 
thus the tools Ellipase, Bucket Fill and Pencil Tools can be used. 

Steps of the Activity 
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Note that: the figure is composed of a group of oval shapes, thus the tools Ellipase, Bucket Fill and Pencil 

Tools can be used. 

Activity (4) Draw an oval shape with green colored borders and fill it with a yellow color. 
1. Open a new file image from File menu  new. 

2. Select the Ellipse selection tool. 
3. Select the green as front color from the tool box.  
4. From the Edit menu choose Stroke Selection, a "Stroke Selection" dialog box appears 
5. Select the line width from "Line width" from the dialog box. Click on "Stroke", the 
borders of the oval shape are drawn with the green color 
6. Select the yellow as front color from the tool box. 
7. From the Edit menu select Fill with FG Color; the selection is filled with the front color with yellow. 
The following figure shows the implementation steps: 

 

Activity (5) By the help of your teacher try drawing the following: 
Using the following tools: 
- Ellipse Select tool. 
- Pencil Tool. 
- The Lasso free selection tool. 
- Bucket Fill Tool. 
 

Save Image 
After finishing the drawing the image, the stage of saving it in the file comes. 
Save Image through the command Save from the File menu: 
The command Save is used from the File menu, since the GIMP program offers the extension XCF to the 
image file, to save all the information about the image (Layers. 
Transparency) This extension is useful in case of reopening the file of the image or modifying it. 
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Remember 

create a new image file through: File menu New. 
In the dialogue box to create a new image: 
1-Templates: are previously ready-made designs prepared of the dimensions and 
the resolution of the image. 
2-Image Size :to identify the dimensions of the new image (length and width) by 
clicking on the arrows . 
3-Advanced Options : to create the new image 
4-resolution : used to determine the image accuracy when printing 
5-Color Space: This is used to determine the Image color scheme RGB or grayscale 
6- Fill with: It is used to specify the new image filling color which can be: 
-Background Color                           -Foreground Color 
-White filling the image in white color. 
-Transparency to make the image background transparent. 
When save the image by the command Save from the File menu: 
The GIMP program offers the extension XCF to the image file, to save all the information about the image 
(Layers. Transparency. ).. 

 

 

Complete the following statements: 
First: To create a new image, the following steps should be followed 
1. Identify the dimensions of the new image. 
2. .................................. . 
3. .................................. 
4. .................................. 
5. .................................. 
6. .................................... 
Second: 
save command is used from the File menu, where the GIMP program offers ..... 
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Lesson 3 Paint tools 

Paint tools are used for different drawing purposes such as free hand drawing, 
create gradient color scheme, merge the current color with the surrounding colors, 
copy part of the picture in another place in the same image... 
The Paint Tools that can be accessed from the Tools Menu 

Or from the Tools Box 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Pencil Tool -1 
The pen in the "Pencil" tool is used for free hand drawing 

Activity (1)                                                                                        

By the help of your teacher, identify the options tool of the 
"Pencil tool", to find out how to change the size and the 
shape of the brush as well as other uses. 
-choose the shape of the brush. 
-choose an appropriate brush size 

 

Drawing using the "Pencil" tool Activity (2) 
By the help of your teacher, draw the following figure 
1- choose the "Pencil tool". 
2- Modify the options of the tool to change the size and 
shape of the brush. 
3- choose Foreground color "red". 
1-choose the front color from the tools box. 
2-select the shape and size of the brush used from the 
Tool Options of the pencil tool 
3- choose Foreground color "red". 
1-choose the front color from the tools box. 
2-select the shape and size of the brush used from the 
Tool Options of the pencil tool 

The day : ...............................................                                            The date :.................................. 
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Blend Tool -2 
The gradient color scheme Blend tool is used to  make color gradation 
 using the front or back colors.  
Modifications are made to the options of the tool to get the gradient color 
 scheme required. 

Activity 
By the help of your teacher, do the following: 
-create a new file. 
-choose the Blend tool. 
-choose the shape of the gradient color scheme. 
-select the direction of the gradient color scheme. 
-Create a gradient color scheme by clicking and pulling in the image window. 

(3) 

Smudge Tool -3 
By the help of your teacher, try to do the following:                                                       
-Use the Picture of the previous activity. 
-Choose Smudge tool. 
-Choose the (shape and size of the brush) from the tools options. 
-by clicking and pulling the tool in the picture to mix the 
current color with the surrounding colors. 
 
 
 

                                    The picture after using the smudge 
 
 

Clone Tool -4 
The Clone tool is used to copy part of the picture in another place 
 (in the same image layer). It is used to modify and reform the images. 
The steps of using the Clone tool: 
- look at the picture to know the part required to be copied. 
- Choose the Clone tool. 
- stop the cursor at the beginning of the place required to be copied 

 

- press the "CTRL" key on the keyboard (the cursor shape changes to ) 
- move to the required place to add the copied version. 
- click by pulling to create the copied version. 
- do not stop clicking and pulling till you complete the copying. 

(5) Activity 
 By the help of your teacher, use the "Clone" tool try to copy part of the picture as follows: 

 



  31                  term Talkha administration - computer orientation - class brochure for the first year of middle school, first  

1-Select the starting point of the 
copying by pressing the Ctrl key 

2- Move to the place of putting 
 new copy 

3- Press by pulling the copied version then 
continue pressing till you finalize the copied version 

 
  

Steps of copying using the Clone tool 
Important notes 

-While copying click by pulling in the copying place till completing the required copied part. 
- By stopping to click by pulling with the cursor then re-clicking by pulling, copying occurs from the selected 
starting point. 
- To control the copying process change the size and shape of the brush used from the Clone tool options. 
Activity (6)      
By the help of your teacher, try to do the following: 
-Check the picture 1 and picture 2 well to identify the differences between them. 
-Use a Clone tool to make picture 1 (original picture) look like picture 2. 
-Use the Smudge tool to mix and blend the color with the surrounding Colors 

 ( 

Steps in the implementation of the Activity 5) 

   
3-magnify the image using the 
Zoom tool to best see the details 

2-click by pulling using the 
Clone tool. 

1-Select the Clone tool, select the starting 
copying area then press CTRL 

   
6- Final shape of the image 5- Modify the difference in the color scheme by 

using the Smudge tool to mix and blend the 
current color with the rest of the colors 

4-Move the rest of the image by clicking on the 
space bar + the cursor 
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Activity (7) By the help of your teacher, Identify the usage of some of the drawing 

tools of the Paint tools such as:  
Use the Ink tool like a fountain pen to control drawing distinguished 
borders and edges with the brush 
Use the Eraser tool to remove a coloring Space of a picture or a drawing. 
Use the Paintbrush tool to draw clearly 

Remember 

Paint tools are used for different drawing purposes, such as free hand drawing, gradient color 

scheme creating, the current color with the surrounding colors merging, to copy part of the 

picture in another place in the same picture ... 

Paint tools: 

The pen in the Pencil tool used for free hand drawing 

The Gradient color scheme Blend tool used to make color gradation using the front or back color 

The Smudge tool used to mix the current color with the surrounding colors 

The Clone tool used to copy a part of the picture in another place (in the same image layer). 
 

 

 

 

Question One :: Mark ( ) by the correct answer and a (x) by the wrong one: 

1. Use the Pencil tool to make a free hand selection. ( ) 

2.The Clone tool used to mix the current color with the surrounding colors in the 

space where the tool is moving. ( ) 

3. One of the selection tools is the Blend tool. ( ) 

4. The Smudge tool is used to copy part of the image in another place in the 

same image layer, it is well known for modifying and reforming images. ( ) 

5. The Eraser tool is used to delete a color space of a picture or an image.( ) 

Question 2: Rearrange the following steps of using the Clone tool: 

(  )stop the cursor at the beginning of the place required to be copied 

(  )look at the picture to know the part required to be copied. 

(  )move to the required place to add the copied version. 

(  )do not stop pressing and pulling till you complete the copying. 

(  )choose the Clone tool. 

(  )press the "CTRL" key on the keyboard (the cursor shape changes to  

(  ) click by pulling to create the copied version. 
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Lesson 4 Transforming and Resizing Tools  

Transforming tools 
Transform tools are the tools used to change the image format either by transforming, resizing, 
changing the image dimensions .to access the tools of the Transform tools go to the tools menu, 
or through the square tools 
 There are more than one tool and each one has a function and a method of use. 

1- Move tool  
The Move tool is used for moving the image or the layers of an image to frame or text. 

Activity (1) By the help of your teacher, identify how to use the Move tool, use the image of the 
previous activity, by clicking and pulling the Move tool the image is moved. 

 

 

 

 

 

 

 

 

 

Activity (2) With the help of your teacher use the Move tool 

 

- Open the image file from the image folder, using one of selection tools ,select the image. 
- To move the selection, continue pressing ALT + CTRL till you move the selection. 

 

.tool is used to cut a part of the imageCrop  Crop Tool -2 

Activity (3) 
 

With the help of your teacher, crop an image using Crop Tool. 
- Open an image file. 
- Select Crop 
-Drag and drop the image to select the needed part. 
- Press Enter from the key board. 

 

 

 

 

 

 

 

 

The day : ...............................................                                            The date :.................................. 
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tool used to rotate an imageRotate  Rotate Tool -3     
Activity (4) 

-With the help of your teacher, rotate an image using Rotate Tool 

- Open an image file. 
- Select Rotate. 
- Drag and drop to rotate the image. 
- Press Enter from the keyboard after finishing 

Steps of the activity 

     
1- The original image                                                                             2- Select Rotate to show dialgo 

box of rotate angle       

                               
  3- Press and drag to rotate the image                             4- Press Enter to finish Rotate. 

4- Flip Tool 
 Flip Tool is used to flip horizontally or vertically an image.  
Activity(5) With the help of your teacher, flip an image. 
- Open an image file. 
- to make horizontal or vertical flip, select Flip tool 
-then from Tool Options dialogue box, select an option 
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Scale Tool -5 
Scale Tool is used to change the dimensions of an    
image [length and width.] 
Activity (6) 
With the help of your teacher, change the dimensions  

of an image . 

- Open an image file. 

- Select Scale Tool. 

- Press on an image to show the dialog box to decide the  

dimensions and imagecorners. 

- Drag and pull to change the dimensions of the image through the dialog box. 

- Press Enter from the keyboard when you finish. 

 

 

Note: You can use Crop tool after changing the dimensions 
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Remember 

Transform tools is used to change the shape of an image by moving 

or resize. The Transform tools can be used from the Tools menu, or from 

the dialogue box. There are different tools, each of which has a function 

and usage. 

Transform tools: 

- Move tool which is used to move an image or image layers or selection or text. 

- Open an image file from the Image folder, Use a selection tool to select a part of the mage. 

-To move a selection, press ALT + CTRL, continue pressing using the Move tool 

to move the selection. 

-Crop tool is used to crop part of an image. 

-Rotate tool is used to rotate an image. 

-Flip Tool is used to horizontally or vertically flip an image. 

-Scale tool is used to change the dimensions of an image. 

Question 1-Tick ( ) or ( X) 

1- Transform Tools are used to change the form of an image through move, resize or 

change dimensions.                                                                                                               (      ) 

2-Move Tool is used to move an image or image layers or selection or text.        (      ) 

3- To move, press Alt + CTRL and continue pressing using the Move tool.          (      ) 

4- Rotate tool is used to crop an image.                                                                   (      ) 

5- Crop tool is used to rotate an image.                                                                    (      ) 

6- Scale tool is used to make horizontal or vertical flip of an image.                       (      ) 

7- Flip tool is used to make change an image dimensions [length, width].           (      ) 

Question 2: Put the following steps in the correct order to use Scale tool: 

( ) open an image file. 

( ) Drag and pull at one corner to change the dimensions or from the dialog box. 

( ) Press the tool on the image to show the dialog box to decide the image dimensions. 

( ) Press Enter from the keyboard after finishing the dimensions. 

( ) Select the Scale Tool. 



  36                  term Talkha administration - computer orientation - class brochure for the first year of middle school, first  

 

 

 

Lesson 5 Image layers  

There is "Layers" tab within tabs box (layers, channels, paths, undo), 

and uses the "Layers" tab to edit, add and control different picture layers, and 

can think of the image layers as slices are placed on top of each. Layers are 

used to assist in the development of the 

components and the details of different pictures so 

that every part or detail of the image in the layer 

mode, can address this part of the picture 

(scanning - rotation - identification ...) without 

affecting the rest of the image parts, representing 

the bottom layer (lower layer) background image 

"background" and come above the rest of the layers 

to contain the rest of the image details. 

Image consisting of several layers is represented as follows: 

    
      The Image layers                                              The image in its final  

Dealing with the Layers  

You can get to the "Layers" tab through: 

-The main interface of the program. Or 

-Through Windows menu → Dockable Dialogs → Layers 

1- Layer visibility - to make the layer visible or invisible. 

2- Layer thumbnail -is a mini format of the layer and the layer name 

appears next to it (and can be changed by clicking on it). 

3- New layer - to add a new layer 

4- Raise layer -to move the layer to the highest level.  

5- Lower layer-  to move the layer to a lower level. 

6- Duplicate layer - to copy the current layer. 

7- Delete layer - to delete the current layer. 

 

The day : ...............................................                                            The date :.................................. 
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Activity (1) With the help of your teacher, add a new layer: 

-To add a new layer, click on the New layer in the "Layers" tab. 

-To show the dialog "New Layer." 

-Press OK, a new layer is added 

 

Note: to deal with the layer, it must be pressed to become the current active Layer. 

 

Images window (the layer that has the image disappears). 

To reshow the layer content, click the layer visibility icon again. 

Activity (3) 
With the help of your teacher, rename the layer: 

To rename the layer, double click on the layer and give 

 it a new name. 

Important Notes: 

- To deal with the layer, you must make sure it is the current  

active layer by clicking on it. 

- For ease of working with one of the layers, you can hide the 

 rest of the layers by clicking on the layer visibility icon and 

 dealing with the required layer icon. 

- You can reorder layers using the arrows up and down  

in the Layers tab. 
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Activity (4) 
With the help of your teacher, try to make a shadow for the following picture: 

Open the image file from the "Photos" folder; try to make a shadow for the image 

 

Steps to implement the activity: 

1. Select the white color in the original image using Fuzzy tool; the white space 

around the flowers is selected. 

Important note: 

-There are some images which may not allow Cut or Delete a part from it. 

-To make the image liable to delete part of, do the following: 

-You must make sure that there is no selection in the image (Select-None). 

- Choose from the list of Layers Transparency and then choose Add Alpha Channel. 

- The Alpha Channel represents the transparency of the image 

2- Press "Delete" key from the keyboard, then selected white space around the 

flowers is cleared. 

3- Insert a new layer with name "Shadow." 

4- from the list Select, Choose Invert to invert the selection and determine 

the shape of flowers. 

5- Make sure that the new layer "Shadow" is the current layer. To change the 

foreground color in gray - Use the Bucket Fill tool to make color packing in 

gray inside flowers selection 

6- Rearrange the layers so that the layer "Shadow" is the bottom layer 

7-to end the selection, from the Select menu, choose none. 

8- Move the upper layer of the flowers using the Move tool to show the shadow. 
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Activity (5) 

  

With the help of your teacher, 

type the text "the beautiful flowers" in the form 

of flowers in the former activity and export 

the image file with appropriate extension 

Steps to implement the activity 

When choosing the text tool, the text box appears 

in which the text can be written and edited. 

A new layer is automatically inserted 

To get Out of the write mode, 

press on any other layer 

 

       

You can get more information about the text tool from the link: 
http://docs.gimp.org/2.8/en/gimp-tool-text.html 

Export image to a file with an appropriate extension 

To export the image as a file with a suitable extension (JPG, ... GIF), 

follow these steps: 

-Ensure that all layers are Visible. 

-integrate all layers, and to merge the layers into 

 a single layer 

choose Flatten Image of the Image menu.  

-From the File menu choose Export, 

select the appropriate extension of the file 

and its name. 

 

 

 

http://docs.gimp.org/2.8/en/gimp-tool-text.html
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Remember 

- the "Layers" tab uses to edit, add and control different picture layers. 

-To make the layer invisible, press on the icon. 

-To add a new layer, press on the icon . 

-To move the level of layer to the top, press on the icon. 

-To move the layer to a lower level, press the icon . 

-To copy the current layer, press on the icon. 

-To delete the current layer, press on the icon. 

-To deal with the layer, press on it so that the current layer becomes "Active Layer." 

-To rename a layer, Double Click on the layer and type its name. 

- When you insert the text, a new layer is inserted and the layer is named 

automatically with words from the beginning of the written text. 

To export the image as a file with appropriate extension: 

-ensure that all layers are Visible. 

-merging all layers, to become one layer, choose Flatten Image 

from the Image menu 

-from the File menu,choose Export, select the appropriate 

extension of the file and type the file name. 

 

 

First question: 

Complete the following phrases: 

The following picture shows the "Layers"  

tab,Explain what each number refers to:  

1. .............................. 

2. .............................. 

3. .............................. 

4. .............................. 

5. .............................. 

6. .............................. 

7. .............................. 

 

 

 

 

 

 

Second question: Order steps to export file with appropriate extension: 

( ) From the File menu choose Export, select the appropriate extension of the file and 

the file name. 

( ) to merge all layers into a single layer, choose Flatten Image from the Image menu. 

( ) ensure that all layers are Visible. 
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Lesson Six it an image using Filters 

 

A Filter is used to help change the apearance of an image. 

To use a filter , select the suitable filter from the Filters  

menu. 

 

 

 

 

1- Blur 

This filter is used to wipe 
out or darkening the 

image. 
Get it from Filters menu 

→ Blur → Blur 

 

Original Image 

 

Image after using Blur filter 

2- Emboss 

(enrichment) 

Emboss is used as 

following: 

Filters menu → Distorts 

→ Emboss. 

 

Original image 

 

Image after using Emboss 

Activity (1) With the help of your 

teacher, open this image 

from image folder, apply 

Emboss 
 

Original image 

 

Image after using Emboss 

The day : ...............................................                                            The date :.................................. 
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3- Page Curl 

(enrichment) 

It can be used as 
following: Filters → 

Distorts → Page Curl. 

 

Original image 

 

image after using Page Curl 

Activity   (2) With the help of your 

teacher, open this image 

file from image folder 

and apply Page Curl filter 

 

Original image 

 

after using page curl 

Notice: When we apply Page Curl, a new layer is added “Curl layer”. 
Discuss this with your teacher 

4-Supernova 

(enrichment) 

Supernova is used as 

following: Filters menu 

→ Light and Shadow → 

Supernova. 

 

Original image 

 

after using Supernova filter 

To reach the appearance as in the image here 
after using the filter, you must modify the 
properties as in the picture on the right. 
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Activity (3) 
With the help of the 
teacher, open the image 
from the pictures folder, 
use Supernova. 

 

Original image 

 

Image after using Supernova 

5- Film 

(enrichment) 

Use Film filter as 

following: Filters menu 

→ Combine → Film. 

 

Original image 

 

Image after using Film 

To reach the appearance as follows, you have to modify the 
properties of the effect as in the dialog box. 

 

6- Weave 

(enrichment) 

Use the filter Weave as 
follows: Filters menu → 

Artistic → Weave 

 

Original image 

 

Image after Weave 

Activity (4) With the help of your 
teacher open the image 
from the images folder 

and use Weave filter 

 

Original image 

 

Image after Weave 
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Notice:When using Wave filter, a new layer called Pasted Layer is added. 

 

After hide image layer 

 

Filter Layer 

 

Filter layer after hide the image layer 

7- Old Photo 

(enrichment) 

This filter is used as 
follows: Filters menu → 
Decor → Old Photo 

 

Original image 

 

image after using the filter 

Notice: in the dialog box of the filter properties when selecting 
“Work on copy” option, the filter is applied to a copy of the image 
file. 

 

Activity (5) With the help of your 
teacher, open the image 
from the iamge folder 
and apply 

“ Old Photo” filter. 

 

Original image 
 

image after using the filter 

8-Map 
Object 
(enrichment) 

This filter is used as 
follows: Filters menu → 
Map → Map Object. 

 

 

Original image 

 

Image after using the Map 

object filter 
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Activity (6)  

With the help of your teacher, open the image from the images folder and use Map Object filter 

                                                   

        Original image                                                   Image after using the Map object filter 

 

 

Remember 

The filter is used to help change the appearance of the image. 

When applying the filter, a new layer is added to the image or a new file is ceated. 

To use a filter, open the Filters menu and select the appropriate filter. 

 

 

 

Question 1: Put ( ) in front of the right sentences and (X) in front of the wrong one: 

1. A filter is used to help change the appearance of an image. ( ) 

2. To use filter, from the “Filters” menu, select the suitable filter. ( ) 

3. When we use „Filters”, a new layer is added or a new file is created. ( ) 

Question 2 : Complete the following: 

In the dialog box of the “Old photo” properties,  

when select “Work on Copy “, this means 

…………………………………………………………. 

...................................................................................... 
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Lesson Seven Image types 

Image types: 
1- Raster Images. 

2- Vector Images 

Raster Images: 

It consists of contiguous points (Pixels), and each image contains rows and 
columns of the Pixels and the higher the number of the Pixels, the greater image 
clarity is, It has a large storage area for the image, and the quality and clarity of 
the picture change when zooming in or out. 

                                                     

 

 

                                                          Part of the picture when enlarged 

 

 

                                                      Of contiguous points (Pixels) 

 

 

  Image Raster  
Vector Images: 
It is characterized by no change in image quality and clarity when enlarged or 
minimized, and it has a small storage area.  

    
Activity (1) 
With the help of your teacher, look for the types of images and the difference between 
Raster and Vector Image. 

The day : ...............................................                                            The date :.................................. 
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Image Mode 
There are three modes of color of the image, and you can change the status or 
condition of the color image through the Mode command in the Image menu, 
namely: 
1. RGB mode. 
2. Grayscale mode. 

3. Indexed mode. 
1- RGB mode 

    RGB mode    
Through the command RGB in the 
Image menu, the colored image is converted to RGB mode, RGB color mode fits 
very much in the case of displaying images and graphics through the computer 
screen. 
RGB mode consists of the primary colors (red, green and Blue), and these 
three colors are mixed and united with different degrees of mitigation, lighting 
and intensity to give each primary color of these colors 256 color degree. 

2- Grayscale mode 

Grayscale mode 
The image can be converted to the color gray case by using the command 
Grayscale from Image list, where Grayscale mode reaches up to 256 degrees of 
gray ranging from black to white. 
An Important note: 
- The image can be converted from RGB mode to Grayscale by selecting the 
command Gray scale from Image menu. 
- But it should be noted that the image will lose its Colorimetric data of 
RGB mode so that the RGB mode for the image cannot be restored again. 

3- Chromatography Situation of the image Indexed mode 

Indexed mode: 
You can convert the image to Indexed mode by using a command Indexed from Image list 
Activity (2) 
With the help of your teacher search for: RGB mode – Grayscale mode – Indexed mode. 
-More information can be found on the link: 
http://docs.gimp.org/2.8/en/gimp-image-mode.html 
 

http://docs.gimp.org/2.8/en/gimp-image-mode.html
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Activity (3) 
With the help of your teacher, try to do the following: 
4- Open an image file in the program. 

5- Change the color mode of the image. 

6- Copy the image from its original file. 

7- Paste the image into a new layer in the other file. 

8- Edit the image layers so that the original image become as follows: 

       
   The original image                                           The image after its modification 
 

Steps to implement the activity 
With the help of your teacher, try to do the following: 
- Open the image file from the "Images" folder. 
- Change the color mode of the image from RGB to Grayscale by selecting 
Grayscale mode from the Image menu. 
Reopen the original image file RGB again so that two files appear on the top of the 
window as shown in the figure. 
- Copy the gray Grayscale image file by selecting all from the Select menu. 
- Go to RGB color image file by click its tab on the top of the image window. 
Paste the image Grayscale in the colored image file RGB through: 
Edit menu              Paste as                New Layer 
- Grayscale image appears after the paste in a new layer on top layer RGB color image. 
-Use one of the selection tools such as Fuzzy Tool to determine part of the gray image. 

      
          RGB mode                                                               Grayscale mode 



  49                  term Talkha administration - computer orientation - class brochure for the first year of middle school, first  

      

      
 

     
Export image file 

After completing the work on the image, image saving stage comes. 
The Save command is selected from the File menu where GIMP program gives extension to 
the image file .XCF, where all information about the image (its layers,transparency …) is 
kept. This extension is useful in the case of re-opening theimage file and editing it. But it 
should be noted that this extension is not suitablefor reading through a variety of images 
programs. 
Export image file using the Export command from the File menu: 
In order for other programs to be able to read the image file, the image must be exported 
through the Export command from the File menu where the appropriate image file 
extension such as (JPEG -GIF - PNG ...) is selected. 
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Remember 

Image types: 
-Raster Images. 
-Vector Images 
There are three modes of color of the image; namely: 
1. RGB mode.                  2. Grayscale mode.                 3. Indexed mode. 

RGB mode consists of the primary colors (red, green and Blue), and these three 
colors are mixed and united with different degrees of mitigation, lighting and 
intensity to give each primary color of these colors 256 color degree. 
Grayscale mode 
The image can be converted to the color grayscale by using the command 
Grayscale from Image menu, where Grayscale mode reaches up to 256 degrees 
of gray ranging from black to white. 
-The image can be converted from RGB mode to Grayscale by selecting the 
Grayscale command from Image menu, But it should be noted that the image 
will lose its Colorimetric data of the RGB mode so that the RGB mode for the 
image cannot be restored again. 
In order for other programs to be able to read the image file, the image 
must be exported through the command Export from the File menu where the 
appropriate image file extension such as (JPEG -GIF - PNG ...) is selected. 
 
 

Tick (√) in front of the right answer and (×) in front of the wrong one: 

1. In the Vector Image, the quality and clarity of the picture change when 

zooming in or out. ( ) 

2. Copy Raster Image is characterized by a change in image quality and 

clarity when enlarged or minimized. ( ) 

3. There is only one color mode of the image ( ) 

4. RGB mode fits very much in the case of display images and graphics 

through the computer screen ( ) 

5. RGB mode consists of the primary colors (red, green and black) ( ) 

6. You can convert the image to the color grayscale using the Grayscale 

command(   ) 

7. You can convert the image from RGB mode to Grayscale mode where 

the image loses its Colorimetric data ( ) 

8. In order for other software to read the image file, the image must be 

exported through the Save command from the File menu ( ) 

9. The image Can be converted from RGB mode to Grayscale mode ( ) 

10. The large size storage area is from the Vector Image defects ( ) 




